Jump to content
Sign in to follow this  
spirit6

MCC Sandbox - Mission making the easy way

Recommended Posts

Hi Shay,

long time no see.... keep up the good work on the MCC. How are you doing at Marsoc, btw?

I changed the MCC a bit for our needs at UGAF.

TeamStatus is included now, so you can switch the groups during the missions.

If you think this would be suitable I can give you the patch. Could be a parameter to turn on and off, maybe.

I also reintroduced the flagpoles 'mcc_flagteleport' at the start location on the desert islands Takistan and Zargabad. Was missing, maybe because there is no LHD ;-) but I like it though.

One major bug I found is located in the mission.sqm at the Charlie SL slot.

The slot demands some 'delta...' gear script and I changed it to charlie...

Would be nice if this fix could be introduced in one of the next releases.

Last but not least I was desperately looking for the paradrop (enemy troops) stuff in 1.6.2 for a session yesterday. Couldn't find it... What did I oversee? Maybe I find it today if I am not so tired ;-) But help would be appreciated...

Regards

Iron Eddie

Edited by IronEddie

Share this post


Link to post
Share on other sites

Jo Eddie,

How is life?

I'm curently busy with some new big change in MCC. So i'm not going to do any bug fixing soon. Hopefully my plans will work out and i'll suprise you soon.

PS Paradrop is still in the first menu under group spawn.

Share this post


Link to post
Share on other sites

Hi, first I would like to congratulate you Sir for a superb mission! I don't remember the last time me and my friends have had this much fun in Arma2.

Your mission has after many years finally motivated me to once more look into the world of scripts, as with my earlier futile attempts at scripting I have no clue at what I am doing... Therefore I have a question that I maybe you or some other friendly soul could help me with.

The thing I am trying to accomplish is turn on the lights on enemy helicopters through the 3d Editor at night.

The line I have tried to attach in the Init field in the editor is as follows:

 this switchLight "ON";

I have also tried to add this line into the init.sqf under Presets without any luck.

It would also be very cool to add a search light to the helicopters as stated in this thread:http://forums.bistudio.com/showthread.php?t=91632&highlight=light

light enableSimulation false; light attachTo [chopp,[0,6.5,-1.2]]; light setVectorDirAndUp [[0, 1.9, -1],[0, -1, 0]];

But this does also not work for me. :(

I know that this must be a real "noob" question and that the answer for sure is somewhere in the forums but we all have to start somewhere. :)

I can add that I have read through the whole thread about MCC and I have also searched the forums for an answer to my question but without any bigger success.

Share this post


Link to post
Share on other sites

Hello Brand.

Well for start, if u'll spawn an helicopter on safe behavior it will keep his light on.

Second, if you would like to command the AI to keep his light on you'll need something like this:

while {alive heli} do {
driver heli action ["lightOn", heli];
sleep 1;
};

It should turn the light on every second, you might want to work with the sleep thing or add an if check to see if lights are off

if (lightIsOn heli == "OFF") then {....};

Third, you can attach lightpost to an aircraft just make sure u named the light post as light and the helicopter as chopp. You'll need to have a man inside it.

Fourth, I would suggest creating a light source and attaching it to the chopper:

light = "#lightpoint" createVehicleLocal position this;
light setLightColor[1.0, 1.0, 1.0]; 
light setLightAmbient[0.0, 0.0, 0.0];
light setLightBrightness 0.5; 
light lightAttachObject [this, [0,0,-10]];

Share this post


Link to post
Share on other sites

I salute and thank you, Shay_gman! :)

I will give it a try this evening!

Share this post


Link to post
Share on other sites

Hi Shay,

first I want to thank you for your quick reply and help with the paratrooper stuff.

I have not used them since they are gone into this menu...

Another thing I would like to talk about is that some AI spawned in a zone in defensiv behaviour ( I just noticed it with defensiv and did not test it in other behaviour modes) seem to go far off the zone randomly and return after they reached a very far away position. I assume they move to somewhere near the start of MCC or pos[0,0,0]?

I am sure you noticed that already. Do you know why this happens and how it could be avoided?

Thanks in advance

Iron Eddie

Share this post


Link to post
Share on other sites

Good afternoon,

I'm using your amazing IED script in my mission. Everything works wonderfully, however when ever you disarm an IED, there is an error, is there anyway you could guide me through the fix for this? Comment out some lines? I believe it has to do with:

_randsound = random 10;

Thanks for any help regarding this issue.

Skelt, aka Bones

Share this post


Link to post
Share on other sites

@IronEddie I'll look into it. It might be that. Can you reproduce? attach the mission file as spoiler or PM it to me.

@Skelt please provide the RPT or the error line. The line you show is just a code line no error there.

Share this post


Link to post
Share on other sites

It's different depending on the outcome, but I just ran it now, and it says "Disarm 4 not found".

Everything works exactly as it should besides for when you complete the disarm action. I'll see what the report pulls now.

Warning Message: Sound disarmfail2 not found

Warning Message: Sound disarmfail2 not found

Warning Message: Sound disarmfail1 not found

Warning Message: Sound disarmfail1 not found

Warning Message: Sound disarm3 not found

Warning Message: Sound disarm3 not found

Edited by Skelt

Share this post


Link to post
Share on other sites

if (_randsound > 5) then {[[_men], ["disarm1",5]] call CBA_fnc_globalSay}

can I add in the sounds and change the

if (_randsound >5) then {[[_men];["sounds\disarm1",5]] call CBA_fnc_globalSay}

confirmed that does not work lol

Edited by Skelt

Share this post


Link to post
Share on other sites

thinking now it has more to do with the discription.ext than the script or sounds folder... going to check some other sources, would really like to get this working error free.

Thanks again,

Skelt, aka Bones.

ED: Ok, i have the sounds in now, so I'm no longer getting any sound errors.. but It's giving a strange CBA error after each action, any ideas?

Edited by Skelt

Share this post


Link to post
Share on other sites

Sorry for not responding for a while been busy.

ED: Ok, i have the sounds in now, so I'm no longer getting any sound errors.. but It's giving a strange CBA error after each action, any ideas?

What kind of error do you get? and, are you using the regular MCC or some hybrid with custom scripts?

Share this post


Link to post
Share on other sites
ED: Ok, i have the sounds in now, so I'm no longer getting any sound errors.. but It's giving a strange CBA error after each action, any ideas?
What kind of error do you get? and, are you using the regular MCC or some hybrid with custom scripts?
You know, THE strange CBA error :D Everyone knows that one!

Share this post


Link to post
Share on other sites
You know, THE strange CBA error :D Everyone knows that one!

Oh that error sure every one know it ;)

Ok guys after long time of absent bouth on scripting and playing, here is an update:

MCC Sandbox is now a mod. It will work with any SP or MP mission and there is no more ACE dependency (sorry Sick) although I strongly recommending using ACE.

So here is the link to the addon thread:

http://forums.bistudio.com/showthread.php?p=2052823#post2052823

There for I request a moderator to close this thread all support for the mission version or the mod version will be done in the mod thread. :yay:

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×