Jump to content
Sign in to follow this  
Dwarden

ARMA 2: Operation Arrowhead - Linux Dedicated server - 1.57.76894 & beta 1.57.76934

Recommended Posts

A2: OA linux dedicated server build 1.57.76894 download:

http://www.arma2.com/index.php?option=com_rokdownloads&view=file&Itemid=20&id=448%3Aarma-2-oa-linux-standalone-server-1-57〈=

A2: OA linux dedicated server build 1.57.76934 beta download:

ftp://downloads.bistudio.com/arma2.com/update/a2oa-server-1.57.76934.tar.bz2

MD5: 6ff243dec361dd89e90bb3848657057b

* beta has working multihome -ip= paramater and all fixes as in the public beta 1.57.76934 http://www.arma2.com/beta-patch.php

Note that it requires Arma 2: Operation Arrowhead data to be updated to version 1.57 first in order to run properly.

Please provide us with feedback to this topic.

Arma 2: Operation Arrowhead - Linux Standalone Server 1.57

===============================================================

Copyrigt © 2010 Bohemia Interactive Studio. All rights reserved.

For more information please visit

http://community.bistudio.com/wiki/ArmA:_Dedicated_Server

Installation instructions:

==========================

1. Following programs must have been installed on your Linux-box:

tar, gcc. Optional: md5sum (for setup integrity check)

1a. On some verions of Linux (this was reported for RedHat 9

and Gentoo linux 2.4.20) the NSCD deamon must be installed to

run ArmA 2 server successfully. Caching of DNS would be sufficient.

2. Copy the whole "ArmA 2 Operation Arrowhead" directory from Windows

to some Linux-directory (arma2arrowhead). DON'T DO ANY DATA CONVERSIONS

(even "dos2unix" translation of text files is not necessary).

Example: you can use PKZIP (WinZip, PowerArchiver, etc.) on

Windows and "unzip" on Linux.

Don't use upper case letters in the ArmA2 directory name

(/home/bob/arma2arrowhead will be good, /home/bob/ArmA2ArrowHead

may cause some troubles).

ArmA2 directory should contain subdirectories "Addons", "Bin",

"Campaigns", etc.

3. Copy the "server-x.xx.tar.gz" (x.xx is version number) file into

the arma2arrowhead directory. Unpack and install it with commands:

arma2arrowhead$ tar -xjf server-x.xx.tar.bz2

arma2arrowhead$ ./install

Watch the messages - they will inform you whether your installation

is successful.

4. Dedicated server can be started in foreground:

arma2arrowhead$ ./server

Or in background:

o$ nohup ./server > out.txt 2> err.txt &

[1] <pid>

5. Running server can be stopped by executing:

$ kill -s SIGINT <pid>

Where <pid> is process-id of mother server thread (printed out in

"nohup" command).

6. ArmA2 ArrowHead server has a feature: command-line parameter

"-pid=<pid_file>". It causes creation of <pid_file> with

PID of root ArmA2 process. If IP port specified in "-port=<nn>"

parameter is busy (in usage), ArmA2 will terminate immediately

and <pid_file> won't be written..

7. The "arma2server" script is provided for automatic server

start/restart/status query/etc. Please be sure to edit

CONFIGURATION PARAMETERS in lines 12 to 18 !

After this is done, install (hard-link?) the script into

"/etc/rc.d/init.d/arma2server" file. After that it can be managed

by "chkconfig" (see info/man).

previous thread about 1.56 beta linux :

Edited by Dwarden

Share this post


Link to post
Share on other sites

Changelog are the same as in Win Server?

[76870] Fixed: Flood in RPT file caused by lines like "Object 2:200 (type Type_268) not found."

[76837] Fixed: Fake server monitor line after client connects.

Share this post


Link to post
Share on other sites
Changelog are the same as in Win Server?

yes but the linux server contains all the changes between last 1.56 beta one and the win :)

Share this post


Link to post
Share on other sites

beta 1.57.76934 released, happy Xmas to everyone

Share this post


Link to post
Share on other sites

When using multihomed parameter (-ip=) with the post-1.57.76934 beta I get...

23:09:42 Dedicated host created.
23:09:43 Cannot start host on port 2302.
Error: createPeer failed
Error: createPeer failed
Error: createPeer failed
Error: createPeer failed
Error: createPeer failed
Error: createPeer failed

I was hoping the option to declare IP explicitly would help with a GameSpy reporting issue I'm experiencing (described HERE). Instead I get no listing (rather than a listing with 2500 ping) and the server cannot be reached at all (even when entering the IP via Remote) though the process continues to run. Thanks.

Edited by Dwarden

Share this post


Link to post
Share on other sites
When using multihomed parameter (-ip=) with the post-1.57.76934 beta I get...

23:09:42 Dedicated host created.
23:09:43 Cannot start host on port 2302.
Error: createPeer failed
Error: createPeer failed
Error: createPeer failed
Error: createPeer failed
Error: createPeer failed
Error: createPeer failed

I was hoping the option to declare IP explicitly would help with a GameSpy reporting issue I'm experiencing (described HERE). Instead I get no listing (rather than a listing with 2500 ping) and the server cannot be reached at all (even when entering the IP via Remote) though the process continues to run. Thanks.

I can launch the Linux 1.57.76934 server with -ip=aaa.bbb.ccc.ddd just fine, so I don't think that's the cause of your problem. Notice the

23:09:43 Cannot start host on port 2302.

Sometimes, when you do ./arma2oaserver stop to stop the dedi, it isn't actually stopped, so double-check that there isn't an ArmA II process running when you try to launch it again. If there already is a server running, it will have "taken" port 2302 and that explains the error message you're seeing. You can use the ps command to show the currently running processes. If an ArmA II server is running there will be two processes related to that - the server itself and a bash process which runs the start script watchdog:

$ ps aux
...
...
16635 pts/0    S      0:00 /bin/bash ./arma2oaserver watchdog
16637 pts/0    Sl     0:18 /srv/arma2/server -server -config=server.cfg -port=2302 -pid=/srv/arma2/2302.pid -cpucount=2 -ip=aaa.bbb.ccc.ddd
...
...

If you then run ./arma2oaserver stop and those two processes aren't gone after that, use the kill command to stop them. Using the results of the above ps command output, I would run

$ kill 16635 16637

to really stop the ArmA II server. The actual process ID numbers will vary, of course.

Share this post


Link to post
Share on other sites

Must have been the case as I just tried it again and the server launched okay and is viewable in the server list (but still with the 2500 ping unfortunately).

Share this post


Link to post
Share on other sites

good , at least we know the multihome is working properly (multiple users confirmed) even on linux :)

i'm afraid the problem with packets must be dealt with Amazon (theirs routers/firewalls/server hosting) or GameSpy (theirs protocol and master server)

Share this post


Link to post
Share on other sites

...I am abroad and unable to patch/update the server for our gamers (just online with usb stick) until 4th January.

Unfortunatly, BI is still unable to provide a update package for Linux with everything included. Can someone help me out with an rsync source to a already patched server?

Share this post


Link to post
Share on other sites

Its not picking up the mod on our server.

...
SERVER=${ARMA_DIR}/server
OTHERPARAMS=-cpucount=2
MOD=@cba

I tried to move @CBA to Expansions too, did not work either.

What am I doing wrong?

EDIT: Found it.

  ${SERVER} >>${LOGFILE} 2>&1 -server -config=${CONFIG} -port=${PORT} -pid=${PIDFILE} -mod=${MOD} ${OTHERPARAMS}

Edited by Sira

Share this post


Link to post
Share on other sites

beta 1.57.76934 seems to be very unstable.

1.57.76894 worked properly about 24 hours without crashes and etc.

with beta 1.57.76934:

Dec 25 16:59:55 g13 kernel: [2500948.973898] server[14805]: segfault at 3c ip 00000000089d70c8 sp 00000000ff909a40 error 4 in server[8048000+100f000]

Dec 25 22:05:38 g13 kernel: [2519283.773286] server[1110]: segfault at 0 ip 00000000083ea20a sp 00000000fff95aa0 error 4 in server[8048000+100f000]

Dec 26 14:58:53 g13 kernel: [2580051.957610] server[26819]: segfault at 0 ip 00000000080deef7 sp 00000000ffbda8e0 error 6 in server[8048000+100f000]

Dec 26 14:59:04 g13 kernel: [2580063.041197] server[20822]: segfault at c ip 0000000008f6a7ad sp 00000000f7343370 error 4 in server[8048000+100f000]

Dec 26 15:02:13 g13 kernel: [2580252.466369] server[25870]: segfault at c ip 0000000008f6a7ad sp 00000000f7363370 error 4 in server[8048000+100f000]

Dec 26 15:03:31 g13 kernel: [2580330.574508] server[17804]: segfault at c ip 0000000008f6a7ad sp 00000000f73f1370 error 4 in server[8048000+100f000]

Dec 26 15:03:50 g13 kernel: [2580349.342379] server[17799]: segfault at c ip 0000000008f6a7ad sp 00000000f73f2370 error 4 in server[8048000+100f000]

Dec 26 15:13:13 g13 kernel: [2580911.361308] server[18184]: segfault at c ip 0000000008f6a7ad sp 00000000f73b9370 error 4 in server[8048000+100f000]

Dec 27 16:19:17 g13 kernel: [2671183.608086] server[6174]: segfault at c ip 0000000008f6a7ad sp 00000000f736d370 error 4 in server[8048000+100f000]

Dec 28 02:18:56 g13 kernel: [2707146.522888] server[19050]: segfault at 42394e09 ip 0000000009053158 sp 00000000f775f328 error 6 in server[8048000+100f000]

Dec 28 02:28:57 g13 kernel: [2707747.371682] server[1764]: segfault at c ip 0000000008f6a7ad sp 00000000f73c2370 error 4 in server[8048000+100f000]

Dec 28 04:12:41 g13 kernel: [2713968.760933] server[6450]: segfault at 0 ip (null) sp 00000000f771a1dc error 14 in server[8048000+100f000]

Dec 28 04:25:16 g13 kernel: [2714723.557308] server[15097]: segfault at c ip 0000000008f6a7ad sp 00000000f7412370 error 4 in server[8048000+100f000]

Dec 28 18:50:36 g13 kernel: [ 445.971518] server[1233]: segfault at e841b32c ip 00000000f756d25b sp 00000000f09fd50c error 4 in libc-2.11.2.so[f7501000+140000]

Dec 28 21:01:14 g13 kernel: [ 8279.417956] server[8290]: segfault at 9 ip 00000000f756642d sp 00000000ff991c98 error 4 in libc-2.11.2.so[f74f8000+140000]

i'm back to 1.57.76894...

P.S. Debian 2.6.32-5-amd64

Edited by MiBF

Share this post


Link to post
Share on other sites

Why you doesn't release the latests betas for linux?

I'm waiting for "[77004] Fixed: Possible ServerCommand abuse by non-admin attackers." and etc...

Share this post


Link to post
Share on other sites

I am not able to spin up OA1.57, followed instructions and get the following:

Anyone know what I am doing wrong and how do I repair this?

Thanks in advance.

"Warning Message: No entry '.CfgWrapperUI'.

Warning Message: No entry '.Cursors'.

Warning Message: No entry '.Arrow'.

Warning Message: No entry '.texture'.

Warning Message: '/' is not a value

Warning Message: No entry '.hotspotX'.

Warning Message: '/' is not a value

Warning Message: No entry '.hotspotY'.

Warning Message: '/' is not a value

Warning Message: No entry '.width'.

Warning Message: '/' is not a value

Warning Message: No entry '.height'.

Warning Message: '/' is not a value

Warning Message: No entry '.color'.

Warning Message: Size: '/' not an array

Warning Message: Size: '/' not an array

Warning Message: No entry '.shadow'.

Warning Message: '/' is not a value

Warning Message: Resource RscDisplayNotFreeze not found

Warning: preNLOD format in object

Critical:Destroying running thread!

Critical:Destroying running thread!

Segmentation fault

"

Share this post


Link to post
Share on other sites

Finally worked to this, was made better by NOT installing as 'ROOT'

HOWEVER, now I have this: ANY IDEAS?

/oa$ ./server

Item str_disp_server_control listed twice

Data file too short 'baf\addons\shapur_baf.pbo'. Expected 768831697 B, got 40500590 B

Critical: Destroying running thread!

I am not able to spin up OA1.57, followed instructions and get the following:

Anyone know what I am doing wrong and how do I repair this?

Thanks in advance.

"Warning Message: No entry '.CfgWrapperUI'.

Warning Message: No entry '.Cursors'.

Warning Message: No entry '.Arrow'.

Warning Message: No entry '.texture'.

Warning Message: '/' is not a value

Warning Message: No entry '.hotspotX'.

Warning Message: '/' is not a value

Warning Message: No entry '.hotspotY'.

Warning Message: '/' is not a value

Warning Message: No entry '.width'.

Warning Message: '/' is not a value

Warning Message: No entry '.height'.

Warning Message: '/' is not a value

Warning Message: No entry '.color'.

Warning Message: Size: '/' not an array

Warning Message: Size: '/' not an array

Warning Message: No entry '.shadow'.

Warning Message: '/' is not a value

Warning Message: Resource RscDisplayNotFreeze not found

Warning: preNLOD format in object

Critical:Destroying running thread!

Critical:Destroying running thread!

Segmentation fault

"

Share this post


Link to post
Share on other sites

You should never run a non-system daemon as root, and never run *any* daemon as root that doesn't do proper privilege dropping to the least-privileged user(generally "nobody"). If the application is compromised(IE, buffer overflow) you just handed over root access to the attacker. Normally, he/she'd have to do a privilege escalation from nobody to root with another exploit/misconfiguration(IE, a setuid program that lets you bang out a fork(!/bin/bash). If setuid, nmap --interactive is an example)

Share this post


Link to post
Share on other sites
Finally worked to this, was made better by NOT installing as 'ROOT'

HOWEVER, now I have this: ANY IDEAS?

/oa$ ./server

Item str_disp_server_control listed twice

Data file too short 'baf\addons\shapur_baf.pbo'. Expected 768831697 B, got 40500590 B

Critical: Destroying running thread!

Did you install BAF on server? Don't do that (on Linux server), just use the light version included in the patch.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×