Jump to content

Recommended Posts

I enjoy the mod thoroughly, good work.

I understand the disclaimer that this is a wip and may be incompatible with other mods. I do have a bit of a query if anyone can shed some light on this it would be nice.

I have a DayZ Lingor server set up with 3 sound mods (acex, jsrs and rws) so players can choose which they like the best or mix and match. I am able to run several other mods with Lingor (so people saying Dayz isn't compatible with other mods is horse manure).

I have set blastcore to run with this server and at rare times it will work and is quite stunning. The majority of other times it doesn't work I get kicked for script restriction #209:

#209 "rs "\warfxpe\ParticleEffects\SCRIPTS\ammo\M242.sqf";

WarFXPE_AZP85=compile preprocessFileLineNumbers "\warfxpe\ParticleEffects\S"

My question is (I've gone to the script text to comment them and change from 5 to 1 etc), is it somehow possible to add an exception to this mod or this particular line? If so, how would it be written?

Share this post


Link to post
Share on other sites
Blastcore is a client side mod. You don't need to run it on your server, unless DayZ works differently.

^ Quoted for truth.

If you use verifySIgnatures=2; ( and I do hope you do ), then you should just add Blastcores server-key to your serverroot/keys folder, and clients will be able to use it. Dont run this on server.

Share this post


Link to post
Share on other sites
^ Quoted for truth.

If you use verifySIgnatures=2; ( and I do hope you do ), then you should just add Blastcores server-key to your serverroot/keys folder, and clients will be able to use it. Dont run this on server.

Yes I do run with verify=2. I removed Blastcore from the startup param's and left only the keys in the root key folder and still getting the same message. Looks like I may not be able to use this (although it runs SMK just fine...shrug).

Edit: So I find the line where this script restriction is kicking from (the ini.sql in blastcore) and decide to comment out those two things. I'm no longer getting kicked for BE but now its obviously the wrong sig file. Would it be frowned upon in the community to recreate new bisign/bikey for this pbo?

Edited by dimedius
Updated progess

Share this post


Link to post
Share on other sites

SQL? That's a database file. Do you mean SQF? If there's an SQL in there I would be a bit concerned.

Regarding the key, you're best off asking OS about that.

Share this post


Link to post
Share on other sites
SQL? That's a database file. Do you mean SQF? If there's an SQL in there I would be a bit concerned.

Regarding the key, you're best off asking OS about that.

Yeah sorry sqf.

Also I posted here in hopes the os will see it too and might give some insight to fix this (and at this point give his permission on minor config adjustments to his work so that itll run on DayZ Lingor).

Edited by dimedius
added content

Share this post


Link to post
Share on other sites

Hi,

does WarFX add dust to the game ? I mean when vehicles are advancing on the ground. Can we set the quantity of the dust ?

Its a 'bit unreal for me when tanks generate a lot dust when advancing on real grassy ground and on asphalt road you know... :)

Edited by Vilman

Share this post


Link to post
Share on other sites

Does anyone play this on a BattlEye enabled server? I play on one server primarily and its not enabled there (trying to see if this is something random with DayZ or BattlEye).

Share this post


Link to post
Share on other sites

Yes you can use it on a server if: The server only needs a signfile (key) enabling you to use this mod on the server. Tough i have seen problems with Blastcore & the Armaholic included signfile thats why we use the Sixupdater file instead, dont know if this is fixed yet

Share this post


Link to post
Share on other sites

I am in reality problem Can you help me .... muzzle flash & explosions Does not work with me in warfx blastcore mod .... can you help me plzzz

I am so sorry for bad English in typing I'm not very good in English ... thanks

Edited by ahmed_wizza

Share this post


Link to post
Share on other sites
I am in reality problem Can you help me .... muzzle flash & explosions Does not work with me in warfx blastcore mod .... can you help me plzzz

I am so sorry for bad English in typing I'm not very good in English ... thanks

blastcore need to run before other addons Example:

-mod = D:\Juegos\Bohemia Interactive\ArmA2;@cba;@cba_a2;@cba_oa;@blascore_visuals_r1.2;@ACE,@ACEX,@acex_ru;@acre;@jayarma2lib_new

In the launcher, go to the tab "addons options" choose @blascore_visuals_r1.2 and climb of position with the green arrows, put it like in the picture and all will work well, CBA first, then blastcore, and then the rest of the addons.

287blast.jpg

Share this post


Link to post
Share on other sites

I applied everything I said me but my problem now is muzzle flash does not work with me Can you help me thank you

Edited by ahmed_wizza

Share this post


Link to post
Share on other sites

Confused as to why there is a separate download for Tracers? Is it provided in the main mod as the R1 description seems to suggest and also provided as a separate download if people just want to run Tracers??

Share this post


Link to post
Share on other sites

I did everything you said to me but same problem in muzzle flash does not work

but the explosions Become more realistic

note:

- i use patch 1.60

- i use beta patch

-my target line :-mod=@CBA;@CBA_A2;@CBA_OA;@blascore_visuals_r1.2;@ACE;@ACEX;@ ACEX_USNavy;@ACEX_RU;@ACEX_SM

- i use arma 2 & arma 2 oa (Combined Operations)

---------- Post added at 18:04 ---------- Previous post was at 17:06 ----------

I applied everything I said me but my problem now is muzzle flash does not work with me Can you help me thank you

Share this post


Link to post
Share on other sites

Muzzle flashes are almost invisible during the day. At night, they make you blind due bad implemenation of the HDR.

Share this post


Link to post
Share on other sites
Yes you can use it on a server if: The server only needs a signfile (key) enabling you to use this mod on the server. Tough i have seen problems with Blastcore & the Armaholic included signfile thats why we use the Sixupdater file instead, dont know if this is fixed yet

I found a temp fix. I changed the script text from one that was about 39kb (fairly recent) to another one that was 42kb (also recent). Ran it and got a script 21 error. Ok look at the log, kicking for some cba event handlers. Take out CBA's from start parameters and works (albeit its gonna pop up with a couple messages saying this or that not found but still runs it fine so far). I will be conducting further testing with this but ladies and gentlemen...I has blastcore running on dayz lingor! lol

Share this post


Link to post
Share on other sites
I found a temp fix. I changed the script text from one that was about 39kb (fairly recent) to another one that was 42kb (also recent). Ran it and got a script 21 error. Ok look at the log, kicking for some cba event handlers. Take out CBA's from start parameters and works (albeit its gonna pop up with a couple messages saying this or that not found but still runs it fine so far). I will be conducting further testing with this but ladies and gentlemen...I has blastcore running on dayz lingor! lol

I think you are just looking for problems if you have errors popping up. Likely it looks like things are running and some things might very well be running but the errors are definitely going to cause odd things to happen most likely. I'd resolve it properly not with some hacky temp semi-fix.

Share this post


Link to post
Share on other sites
I think you are just looking for problems if you have errors popping up. Likely it looks like things are running and some things might very well be running but the errors are definitely going to cause odd things to happen most likely. I'd resolve it properly not with some hacky temp semi-fix.

True, although I've played some regular arma II servers in the past with different addons that cropped up with random missing config files but it seems to play fine. I'm not trying to disregard problems coming up but with my limited scripting capabilities and OS not responding (I know he's a busy guy) to my PM this is the best solution so far.

I will be monitoring for any issues that may pop up. Any known ways to create an exception into the script text (line #209 to be exact) or reconfigure the original blastcore pbo's with suitable bisign and bikey I will be listening with all ears :)

Share this post


Link to post
Share on other sites

I am noticing the tracer mod turns tracers invisible on thermal sights. Is there any way to make them show up there again?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×