Jump to content
Sign in to follow this  
commander1985

Weird Binarize Error

Recommended Posts

Hey Folks, im working on a new island and now got a very weird error in the .log.

Warning: Embedded material ca\plants2\clutter\data\c_grassautumn_t.rvmat differs - repack data

source used: ca\plants2\clutter\c_grassautumn_t.p3d

source ignored: ca\plants2\clutter\c_grassautumn_t.p3d

hint: ca\plants2\clutter\c_grassautumn_t.p3d is older

This seemed to happen from one day to another, i never altered the files as these are bis standard ones. i even unpboed the original files from arma2 again and put them on my p: drive with the same result. I have no clue why this happens or how to fix this bug. Any suggestions?!?

Most strange of all is that the map works fine in Singleplayer without errors in the clutter. But when i want to load the map on our server to test it with my friends/members it just throws me back to the lobby....

If it helps heres my config.cpp not sure if its caused by it.

http://pastebin.com/TDzUfG9r

Looking forward to a quick solution.

P.s. sorry if theres already a post about it but i couldnt find something that really fits.

Share this post


Link to post
Share on other sites

i don't think so, i have also included them with ovaron. so i guess they are needed.

But i will try it. Other thing i have in mind is that i have a problem with visual c++ since a dll is broken, maybe that is causing the trouble. i pbo ovaron some weeks ago (last update) all was fine, then dll got broke now i have some trouble in some applications Oo

If your suggestion doesnt work i reinstall my windows :P Maybe that helps. Had to do that anyway^^

Share this post


Link to post
Share on other sites

Looking after the class CfgSurfaceCharacters

I have been unable to find "CMMGrassAutumn_t" in one of the defined clutters.

Share this post


Link to post
Share on other sites

Yep thats true, i just took my old class CfgSurfaceCharacters from Overon to get started. But since there are some class CfgSurfaceCharacters defined there that are not used too i dont think they make the trouble. However i take em out when i got the time for it and see if it helps.

Share this post


Link to post
Share on other sites

Do you binarize with BinPBO? Try to check "Clean temp folder" and see if it helps. The error message isnt really clear, but I can tell you at least that binarized models have their materials embedded (yeah, that means most rvmats are not needed in a pbo) and the embedded material in the ca\plants2\clutter\c_grassautumn_t.p3d seems to differ with another source. I would have thought the original rvmat but the error states the same path again what makes it sorta confusing.

Share this post


Link to post
Share on other sites

Yep i tried binarize with BinPbo as usaual. I cleared the temp folder my self, maps still binarizing but the error showed up in the log again. I could try it without the rvmats. Which means deleting them in p: drive, well atleast those of the clutter (dont need textures for clutter in buldozer since they are not shown, unless i want to place em manually). Still very confusing.....

Share this post


Link to post
Share on other sites

OMG!!! I always had that extension in it! No idea why it disappeared! adding it now and trying again! Thanks for the tip! im pretty sure that might do it :)

---------- Post added at 07:40 PM ---------- Previous post was at 06:53 PM ----------

Okay i hoped too much, error is still there :(

Share this post


Link to post
Share on other sites

Have you deleted all BinTemp content before binarizing ?

Manually I mean for BinPbo don't like to delete the things even if the box is ticked.

Have you renamed all the clutters or are you using the same names as on your previous map ?

Share this post


Link to post
Share on other sites

Yep i deleted every temporary content manually.

And yes clutter was all renamed. If i won't do so the clutter would just show up on one map if i load both up in arma2. Tonight i reinstalled windows, i will test this afternoon if it works now. As i mentioned in the first posts i had troubles with my visual basic which is now gone (memcpy_s in msvcrt.dll). If it works now i know what was causing the trouble :) Atleast avenue script is working again :P

Share this post


Link to post
Share on other sites

Let me asked a trivial question , as you have already released map I believe it's quite unimportant ... but let's try it ^^.

Are you building your map according to "Synide recipe" as set on ArmA Build Environment - Setup & Usage ?

I mean are you using a special building space ? So the path to your project is :

P\my_buiding space\my_terrain\source\my_terrain.pew

Share this post


Link to post
Share on other sites

yes,

Spritz Island is on P:\shez\spritzisland\source\terrain\spritz.pew

Fallujah is on P:\shez\fallujah\source\terrain\fallujah.pew

the CA config files are in P:\shez\ca

Share this post


Link to post
Share on other sites

Here what's said in the Holly Scriptures : Don't Do It !

Build a CMR building space hosting your project in P such as :

P\CMR\cmr_cicada\source
Edited by Old Bear

Share this post


Link to post
Share on other sites

Commander1985,

There are essentially 2 ways to setup your folders and stuff over on your 'P:\' drive.

It's completely fine to use 'P:\cmr_cicada\...' type of setup.

In which case when you run BinPBO you should tell it the 'Path To Project' folder is 'P:\' and your stuff should build alright. If, ofcourse you have the BIS content extracted to 'P:\ca' etc.

This will mean your end result pbo will have a pbo prefix of 'cmr_cicada' which again is totally fine and the physical filename of the .pbo will be 'cmr_cicada.pbo'.

The other way of setting up your P:\ drive folder structures is sorta detailed in that document I put out a while back. I mainly did it that way primarily because I was helping a number of different groups of people with their content dev. at the time and it was darn nice to have that content all live seperately in their own 'namespace' folder on the 'P:\' drive and still have the build tools work & O2/V3 as well. Also, it replicated the BIS folder structure.

The result if you went with the 2nd. method is that the pbo prefix would be 'cmr\cicada' and the physical filename would be cicada.pbo. Which, you'd then simply rename to cmr_cicada.pbo.

Either way is ok. But, you should choose one or the other and stick with it.

Personally, I preferred the method I tried to described in that document because it made a very clear demarcation between the various content that maybe under development on your 'P:\' drive.

That being, everything 'Commander1985' related lived down under 'P:\cmr\...' and everything that you & joe & bob & harry have been working on for the TBTM mod (The Bloody Terriffic Mod) lived down 'P:\tbtm\...'.

Many find the way in which you currently have it setup the easiest. Primarily because it's a 'no brainer'. Others, mainly people doing content for numerous different 'groups' may prefer the 2nd method. But, it requires a little more thought to confgiure and maintain properly.

One thing you shouldn't do though in my opinion is place your content down under p:\ca. There's just simply no reason todo so and that's all BIS related stuff under there. Your content should live somewhere else...

Cheers, Sy.

PS. If you did go with Old Bear's suggestion I'd suggest a slight modification in 'P:\cmr\cicada\...' be your setup. As mentioned above. The outputted .pbo from BinPBO would be cicada.pbo which you'd rename to cmr_cicada.pbo. This is what I do.

The only trouble with you changing it now is that you'd have to repath the .rvmat's, config's, models, etc. in your content which is a bit more work for you. I think Mikero might have a couple of tools to help you achieve that pretty painlessly. They can be found over at DH if needed.

Also, ALWAYS make sure that your output/destination folder for your .pbo is a '<mod folder>\addons' under your Game Installation so that in the case your outputted .pbo will never collide with an existing pbo named file.

Edited by Synide

Share this post


Link to post
Share on other sites

Okay thank you guys for the advice, maybe i check this out tonight.

I readed your guide synide and it teached me alot when it was starting to do maps in arma2. Must have somehow missed the point with the namespace.

Everything else is pretty clear, since i just started trying to do my own 3d models they are not placed yet in the maps or ca\ folder... the only content in the ca\ folder is from bis! i do know that i should never ever put anything from my stuff in it. But thank you for reminding me :)

Share this post


Link to post
Share on other sites

Okay im sticking with Synides Way of doing it.. I made a namespace and put my cmr_cicade folder in it. Edited all configs, rvmats etc reimported the sat and mask lco's etc.

Now i wanted to go binarize and see what happens... Well its crashing because of this:

Cannot load font core\data\fonts\lucidaconsoleb8

Fonts file \core\data\fonts\lucidaConsoleB8 not found

Cannot load font core\data\fonts\lucidaconsoleb11

Fonts file \core\data\fonts\lucidaConsoleB11 not found

<model = "p:\cmr\cmr_cicada\ClutterCutter.p3d">

</model>

<world = "p:\cmr\cmr_cicada\cmr_cicada.wrp">

Cannot open object core\default\default.p3d

Cannot open object core\skyobject\skyobject.p3d

Cannot load font core\data\fonts\tahomab16

Fonts file \core\data\fonts\tahomab16 not found

Cannot open object ca\data\blesk1.p3d

Cannot open object ca\data\blesk2.p3d

Cannot open object ca\data\mrak1.p3d

Cannot open object ca\data\mrak2.p3d

Cannot open object ca\data\mrak3.p3d

Cannot open object ca\data\mrak4.p3d

Cannot open object ca\plants2\clutter\c_grasstall.p3d

What is goin on now?!? I have my P: drive and want to binarize from it. i have P:\ca\ with its orginal bis content. And i got a copy of the needed .cpp's in my cmr\cmr_cicada\ca\ folders... I also put them into P:\cmr\ca\ to see if it helps, but i get the same error over and over again.....

Share this post


Link to post
Share on other sites

Hi Commander1985,

Ok, well that's cool. Takes a little bit to iron things out.

Uhuh, so P:\cmr then.

You mentioned you placed the duplicate BIS configs into P:\cmr\cmr_cicada\ca.

It doesn't live there but one level up in P:\cmr\ca\... So, in Windows Explorer just Left-Mouse-Click and drag it up one level.

When you run BinPBO you'll be telling it to build 'P:\cmr\cmr_cicada' and over on the 'options' tell it the Path to Project Folder is 'P:\cmr'.

Regarding the duplicate 'ca' folder you have moved into P:\cmr.

Hopefully you created this using the DOS xcopy command. This is because all that needs to be in P:\cmr\ca\... is the various BIS config files in their various folders and subfolders.

So, there should be a P:\ca\... - This folder and it's subfolders should have all the extracted BIS content under it.

And, seeing as you're adopting the 2nd method. You'll now have a 'duplicate' 'ca' folder structure sitting in P:\cmr with all the same subfolders as in 'P:\ca' but with only the config's sitting in the various folders.

As for the 'core' related messages in your log. Extract the game 'core.pbo' and copy the extracted information to your P:\ drive.

Regarding the 'Cannot open object ca\data\blesk1.p3d' types of messages.

Tbh, I cannot remember if the mlod versions of ca.pbo are included in the tools suite or not, it's been such a long time.

But, it doesn't matter. Goto your P:\ca\data folder. According to the log message it couldn't find 'blesk1, blesk2...' etc.

Double check that they are not there. And if they are not go over to your Game Installation and find the \Addons\ca.pbo.

This maybe as an example 'C:\Games\A2\Addons\ca.pbo'. Extract the ca.pbo in-place. And, you'd end up with 'C:\Games\A2\Addons\ca\...'.

Copy the contents of this folder to your P:\ drive.

The last warning messgae in your log there is... 'Cannot open object ca\plants2\clutter\c_grasstall.p3d'.

Do you have A2? You should extract 'plants2_Clutter.pbo' from your game installation over to your 'P:\'.

Remember wherever you extract a .pbo you should check the pbo prefix text file created to work out where on your P:\ drive you should place the data.

Share this post


Link to post
Share on other sites

Well 1 good and 1 bad News.

Namespace folder is working and binarize works again. Had all the stuff right but i made a mistake in the binarize settings.

The bad news is that i now get the old error again:

Warning: Embedded material ca\plants2\clutter\data\c_raspberry.rvmat differs - repack data

source used: ca\plants2\clutter\c_raspberry.p3d

source ignored: ca\plants2\clutter\c_raspberry.p3d

hint: ca\plants2\clutter\c_raspberry.p3d is older

I could cry :( I even extracted the original p3d's to p: drive again. And i still encounter the old phenomena. binarize ovaron: all fine binarize cicada: above error ....

Share this post


Link to post
Share on other sites

Problem solved!

I had the clutter p3d's place on my object area on the map (kinda libary to find things quickly :) ) i deleted them and all of the mentioned errors are gone now :)

However i still wonder why plants2\misc\trunk_something was causing this too..

Just one more Question! Will this error appear generaly why i place some clutter p3ds manually or just when i place some that are used in the mask/clutterconfig and are definitly used for procedually placement?

Thank you all for your help, its much appreciated :)

Share this post


Link to post
Share on other sites

Okay i tried it sometimes, there are no bad errors in the config anymore, however if i load the map with a picturemap configured in the config cpp it loads arma but i cant start it plus error message that it could not find it... if i dont use it and binarize the game wont start.. it keeps loading for ages!

Share this post


Link to post
Share on other sites

To me, all these errors are referring to paths.

So, if you have rebuilt your building space along the lines I suggested, let do some controls before tearing the whole thing apart :

1° Dumb question ... are you using Visitor3 for ArmA2 ?

2° How is set the path to project in Visitor Preferences ?

Here is a pic of how it shows for my own Tropica map :

http://membresado.free.fr/images/max/1273600554.jpg

Project Preferences > Folder - Textures > P:\cmr\cicada\data

Project Preferences > Folder - Objects > [left blank]

You must write CA in "Folder - Objects" only if you are certain not to use other objects than those from BIS for CA is BIS space.

3° How is build your CA\plants2?

Do you remember that after you have unpbo all the vegetation addons, you must gathered them in an unique CA\plants2

After de-pebo you have :

P:\CA\plants2_tree

P:\CA\plants2_bush

P:\CA\plants2_clutter

P:\CA\plants2_misc

P:\CA\plants2_plant

You must create a P:\CA\plants2 directory where to paste the 5 files after renaming them in order to have :

P:\CA\plants2\tree

P:\CA\plants2\bush

P:\CA\plants2\clutter

P:\CA\plants2\misc

P:\CA\plants2\plant

4° Have you add the unpbo Data file to your CA ?

Share this post


Link to post
Share on other sites

1° Check

2° i used the cluttercutter from a1 but i remove it now for testing so i go point out to

P:\ca\ here (cluttercutter worked on ovaron map) however i would like to use my custom stuff later here :) trying to create some stuff

with oxygen right now

3° Check

4° p:\ca\ has decompressed pbo files; p3d's, configs etc)

P:\cmr\ca\ contains just configs from buildings / 2 , misc /2/3 ,roads2 , structures.

Seemed to be the only needed configs because using all configs in my ca\config stuff

caused my ovaron map to not load anymore after the patch from a2 1.6 - 1.7

Edit:

@2° Pointing out to p:\ca causes no objects to be loaded in visitor3.... took it out again...

Edited by Commander1985

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×