Jump to content
tophe

Tophe's Arma Dedicated Server Tool (TADST)

Recommended Posts

One thing I have noticed, there isn't a option to make waypoints permanent. AFAIK you have it fade out after a few seconds right now for the waypoints option.

Share this post


Link to post
Share on other sites

Hey, tophe, or anyone else that wants to help, i have a problem with the group indicators disappearing at 50 meters, is there any fix to this?

It might be connected to the fact that some of the difficulty settings now have three settings (0,1,2) and TADST so far only supports on/off (0,1). So it might be that the indicator setting can be off/fade after 50 meters/show always. Haven't looked into it but that's my guess.

 

Will fix that in a future release.

  • Like 2

Share this post


Link to post
Share on other sites

Just a quite note to say Thanks to Tophe, great program. Keep up the good work.

 

So handy.

 

Gav

  • Like 2

Share this post


Link to post
Share on other sites

Great program tophe, setup was a breeze.

 

Only thing I can't work out how to do is set the in-mission parameters to how I want them before creating the server.

 

I'm use to hosting a mission where the host has access to set the mission parameters up before you start.

 

Could anyone who knows how post how to do it.

 

CB.

Share this post


Link to post
Share on other sites

CB you either need to be logged into game onthe server as admin before game start or edit the description.ext then upload edited version is mission to the server

Share this post


Link to post
Share on other sites

CB you either need to be logged into game onthe server as admin before game start or edit the description.ext then upload edited version is mission to the server

Thanks KevsNoTrev.

 

CB.

Share this post


Link to post
Share on other sites

It might be connected to the fact that some of the difficulty settings now have three settings (0,1,2) and TADST so far only supports on/off (0,1). So it might be that the indicator setting can be off/fade after 50 meters/show always. Haven't looked into it but that's my guess.

 

Will fix that in a future release.

 

Yes, that's exactly the issue for disappearing Group Indicators. We need a new way of selecting between the three new custom difficulty states (never,limited,always), perhaps with radio buttons. This also applies to other new situational and personal awareness options in server.Arma3Profile including:

/* Situational awareness */
groupIndicators = 0;    // Group indicators (0 = never, 1 = limited distance, 2 = always)
friendlyTags = 0;       // Friendly name tags (0 = never, 1 = limited distance, 2 = always)
enemyTags = 0;          // Enemy name tags (0 = never, 1 = limited distance, 2 = always)
detectedMines = 0;      // Detected mines (0 = never, 1 = limited distance, 2 = always)
commands = 1;           // Commands (0 = never, 1 = fade out, 2 = always)
waypoints = 1;          // Waypoints (0 = never, 1 = fade out, 2 = always)
/* Personal awareness */
weaponInfo = 2;         // Weapon info (0 = never, 1 = fade out, 2 = always)
stanceIndicator = 2;    // Stance indicator (0 = never, 1 = fade out, 2 = always)

(snipped from BI's server.ArmaProfile page)

 

My players keep shooting each other and spend too much time asking "where are you?" without groupIndicators = 2.  :) 

 

I have tried manually editing a few 2's into server.Arma3Profile and setting it to read-only, but TADST throws an unhandled exception error when trying to launch the server. It obviously needs to save changes to server.Arma3Profile and cannot continue. For now, I simply use TADST to set up everything, then paste the Parameters line from it into a batch file to launch my server. That way, my write-protected server.Arma3Profile is read happily and all the other time-sucking trickiness is done in TADST.

 

Many thanks for your hard work on this awesome utility and I look forward to any future updates.

Share this post


Link to post
Share on other sites

Love this thing but one thing bugs me especially since I had to delete my profiles can we have a thing to add mods on mass?

Share this post


Link to post
Share on other sites

Love this thing but one thing bugs me especially since I had to delete my profiles can we have a thing to add mods on mass?

Multi select your mod folders and then drag and drop them into the TADST mods tab.

Share this post


Link to post
Share on other sites

You are a scholar and a gentleman. Thanks for this excellent tip. I had no idea they added the third option and we have been "dealing with" the fade out. Casual players like the crutches you know.  =)

 

Edit: This was supposed to be a direct reply to AstroRetro regarding the server.Arma3Profile tip.

Edited by y_t

Share this post


Link to post
Share on other sites

Would be a good idea for the next update to add a "forcedifficulty" option to TADST.

 

At this time i need to add this  " forceddifficulty="custom"; " to the config.cfg when the file is created.

 

This option force the difficulty of the server even when you change your mission by vote or admin...Really useful...

 

Thaks again for this useful utility tool :).

  • Like 2

Share this post


Link to post
Share on other sites

Hello Tophe,

 

I use TADST from several month now on multiple server and on my own machine.

 

I don't know if some body have the same problem but:

 

On my new dedicate win server I can't drag and drops the addons. On my personnal computer no problem its work.

 

Its not easy to add more than 60 addons one by one...

 

 

If somebody have a solution, it will be super!

 

 

 

 

Tks for your work!

Share this post


Link to post
Share on other sites

if i want to set up HC

 

it enough to do 

 

Tick the box to enable HC on TADST
Place the HC Module from Game Logic in Editor and make playable.
and put the relevent script?

Share this post


Link to post
Share on other sites

Hello everyone,

 

first of all thanks for this nice tool and thanks to TheTrinityNetwork for his clear and nice tutorial for the dedicated server installation.

 

I´m a new ARMAIII user and i would like to know how should i do to set addons working with the the TADST ?

 

What i´ve done first is download the @CBA and @TASK_FORCE_RADIO and paste the two folders in the dedicated directory (pic1 below) .I leave unchecked in the MOD section and i can join the server 

 

http://www.servimg.com/view/17935186/1081

 

But in this case, for example the TASK FORCE RADIO will not work.

 

 

Second attempt i check the @CBA and @TASK_FORCE_RADIO in the MOD section , run the server , no problem.

 

http://i35.servimg.com/u/f35/17/93/51/86/tadst_12.png

 

In parameters:  -port=2302 "-config=C:\arma3server\TADST\default\TADST_config.cfg" "-cfg=C:\arma3server\TADST\default\TADST_basic.cfg" "-profiles=C:\arma3server\TADST\default" -name=default -filePatching "-mod=@CBA_A3;@task_force_radio"

 

 

Here is the problem .If i try to join the server

 

http://i35.servimg.com/u/f35/17/93/51/86/tadst_15.png

 

So i gnore and join the server but here is the message receveid:

 

http://i35.servimg.com/u/f35/17/93/51/86/tadst_11.jpg

 

I delete the files as requested :

 

http://i35.servimg.com/u/f35/17/93/51/86/tadst_13.png

 

But now trying to join the server  after:

 

http://i35.servimg.com/u/f35/17/93/51/86/tadst_10.jpg

 

Does anyone know how to set the TADST with mod without getting errors message when trying to join it ?

 

In advance thank you for the support.

 

 

 

Share this post


Link to post
Share on other sites

Ok , i´ve found the solution....The only thing to "UNCHECK" in the TADST interface is the  UPNP if you run in on a different computer 

Share this post


Link to post
Share on other sites

@christianklein

 

Watch this and don´t forget to uncheck the UPNP ;)

 

Share this post


Link to post
Share on other sites

Hello guys!

 

TADST is really a wonderful tool! Thanks for all the great work!

I'm having an issue and maybe some of you can help me: any changes made in the difficulty window seems not to be applied (3rd person view unchecked by example). I've tried some manual changes inside the TADST profile config to correct this, but again, not seems to have any effect. Do you guys have an idea where I can modify those parameters for my server?

I'm running a dedicated server, no uPNP, and everything else seems to be working without any issue. 

 

Thanks for your help,

 

Edit : I've seen this post from KevsNoTrev:

 

 

Since 1.58 only way to change default settings is to create a custom difficulty.

You then need to go to the missions tab and select your mission. Then select custom from the difficulty.
Save and launch

 

So I just have to change the difficulty in the mission directly and it will work fine?

 

Edit2: found my answer, it was on the mission tab. Sorry for the silly question.

 

 

Zul

Share this post


Link to post
Share on other sites

I'm not very good with this whole hosting things I just want to host a server, how do I start my mission?

Share this post


Link to post
Share on other sites

Not at pc right now Cade, but there should be something like server path. This needs to be the path to the arma3server.exe

Double click for default path.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×