Jump to content
tophe

Tophe's Arma Dedicated Server Tool (TADST)

Recommended Posts

It says "add extra parameters not yet implemented". So parameter settings don't work or when you try to run multiple ones?

Share this post


Link to post
Share on other sites

I'm guessing this doesnt work for Arma Cold War assault? Ive tried this on every single Arma and it doesnt work on that. Nice program though, it helps wonders. But does anyone know a similar program for cold war assault?

Share this post


Link to post
Share on other sites

I also cannot ban players, only kick them.

I was wondering- The checkbox that says "Kick Duplicates?" I have that unchecked so I can play with a group of friends or my brother on my own wifi network. However, they cannot connect. Only one person at a time can be in the match. So, after a little looking around, I saw the side script. (doubleIDconnected=) I was wondering if there is an allow script or something.

Thanks in advance-

Gavin

Share this post


Link to post
Share on other sites

Yeah I cant seem to find any Arma 2 server file V1.11 for windows.. Sadly I cant host on Arma 2, but on Armed Assault and OA, It's perfect!

Share this post


Link to post
Share on other sites

I get this problem while trying to launch CO:

=====================================================================

== C:\Program Files (x86)\Steam\steamapps\common\arma 2\arma2oaserver.exe

== "C:\Program Files (x86)\Steam\steamapps\common\arma 2\arma2oaserver.exe" -port=2302 "-config=C:\Program Files (x86)\Steam\steamapps\common\arma 2\TA2DST\Dedicated\TA2DST_config.cfg" "-cfg=C:\Program Files (x86)\Steam\steamapps\common\arma 2\TA2DST\Dedicated\TA2DST_basic.cfg" "-profiles=C:\Program Files (x86)\Steam\steamapps\common\arma 2\TA2DST\Dedicated" -name=TA2DST "-mod=C:\Program Files (x86)\Steam\steamapps\common\arma 2 operation arrowhead\@beton;C:\Program Files (x86)\Steam\steamapps\common\arma 2 operation arrowhead\@Blastcore_Visuals;C:\Program Files (x86)\Steam\steamapps\common\arma 2 operation arrowhead\@Carraigdubh;C:\Program Files (x86)\Steam\steamapps\common\arma 2 operation arrowhead\@CBA;C:\Program Files (x86)\Steam\steamapps\common\arma 2 operation arrowhead\@CBA_A2;C:\Program Files (x86)\Steam\steamapps\common\arma 2 operation arrowhead\@CBA_OA;C:\Program Files (x86)\Steam\steamapps\common\arma 2 operation arrowhead\@DayZ;C:\Program Files (x86)\Steam\steamapps\common\arma 2 operation ar=====================================================================

Exe timestamp: 2012/07/25 12:43:06

Current time: 2012/09/05 00:18:26

Version 1.62.95251

Warning Message: No entry 'bin\config.bin/CfgInGameUI/MPTable.shadow'.

Warning Message: '/' is not a value

Share this post


Link to post
Share on other sites
I get this problem while trying to launch CO:

That's just because TA2DST.exe is not in the same folder as arma2coserver.exe. Just move TA2DST.exe to the Arma 2 CO install directory.

Share this post


Link to post
Share on other sites
That's just because TA2DST.exe is not in the same folder as arma2coserver.exe. Just move TA2DST.exe to the Arma 2 CO install directory.

TA2DST and all required folders are in the OA install directory. I have the steam version of the game, I play CO all the time, but launching as server does not work. The installation of both arma 2 and operation arrowhead are fine, I just need to find a way to combine the two without TA2DST whining all the time. I have tried this on a server, and my gaming rig; two completely different systems (the former running Server 2003 and the latter Windows 7 Professional), which means that the problem is to do with the installation of 'combined ops'. or whatever method of installation is most compatible with TA2DST. I've been looking for an answer for two months now, I have reinstalled steam on the server, and arma 2 and OA, and all drivers are up to date. I have tried putting arma 2 in the OA directory, and launching arma 2 as a mod, and vice versa. This is really annoying.

I have posted earlier on this very thread about this problem, but I get vague answers like "run CO and OA" or "update drivers". I've tried everything, and I'm tired of getting the same old result.

Thanks for your input nonetheless, and any help at all will be appreciated :)

***EDIT***

Found solution here

Edited by jaydotosh
Re-wording

Share this post


Link to post
Share on other sites
This is just pathetic. Found the solution myself.

Pathetic in which way? You mean pathetic as in waisting other peoples time with your questions but not sharing the solution yourself? Yes, that is pretty pathetic.

Share this post


Link to post
Share on other sites

I think you misunderstood my comment, I was referring to the solution being pathetic. Was't referring to this thread or BI forums in any way whatsoever :)

Share this post


Link to post
Share on other sites

Ok, sorry for the misunderstanding than!

However, pathetic mistake or not, why not share how you solved it with the rest? Everyone can make a simple mistake and if you figured out how to solve your simple mistake share it so others do not suffer the same faith :)

Share this post


Link to post
Share on other sites
Ok, sorry for the misunderstanding than!

However, pathetic mistake or not, why not share how you solved it with the rest? Everyone can make a simple mistake and if you figured out how to solve your simple mistake share it so others do not suffer the same faith :)

I was away yesterday, and I stopped checking BI forums for a reply :)

Edited my original post, though

Share this post


Link to post
Share on other sites

The solution to launch a combined operations server with TA2DST would be REALLY precious man :) Please share with us.

Share this post


Link to post
Share on other sites

Hello there :)

This is a great tool, i was wondering if there are any updates on the process monitoring / restart on crash functionality.

Thanks!

Edited by Tex_Willer

Share this post


Link to post
Share on other sites

Banning is not working on my server, could you please help me why it isn't? BattlEye is set up correctly, and running. If I click "ban" , nothing happens. Kicking does.

Share this post


Link to post
Share on other sites

How i've got the ability to run a Combined Ops Server with this tool (great tool by the way!):

Installed Win 7 on Host Machine

Install Microsoft's Netframework 4.0 or higher (i believe v4.5 works as well)

Installed both Arma 2, then OA (either in the same folder or separate, does not matter)(its can be changed)

Then run both games to ensure that registration files where written.

Personally i exported my Reg files and then copied my Game files to the server.

C:\arma 2 operation arrowhead\

Some Magic: Because my content was stored in 2 separate folders i copied the contents of Arma 2 into the Arrowhead folder. (steam separates the 2)

reg magic: because Arma 2 OA will not find the files when asked for the arma ones now, you have to edit a few registry settings so that they reflect the new location of the arma files.

the reg key will look somewhat like this:

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Bohemia Interactive]

"MAIN"="c:\\arma 2"

You need to change it so that it reflects where the files actually are being kept:

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Bohemia Interactive]

"MAIN"="c:\\arma 2 operation arrowhead"

That the hard part over. :-)

now all you have to do, is when you launch the TA2DST, in the "Parameters" field add the line: "-mods=arma 2;Expansion;ca" (with quotes)

This should open the Server with the Arma 2 Combined Ops files. Easy!

Although i have found that if you refresh the mods list, it deselects the first mod in the line, make sure that if you do refresh the list, re-check the top mod (my mod at the top of the list happens to be the wonderful @ACE, which stops the server server from running)

Share this post


Link to post
Share on other sites
The solution to launch a combined operations server with TA2DST would be REALLY precious man :) Please share with us.

Read my original post, which is on Page 30 towards the bottom ;)

Share this post


Link to post
Share on other sites

Hey thanks for the tool Tophe, works very well from the first start, but I can not change the Parameters inside the game, I dont have the Edit button...and this setting is essential for me as a Server Admin... cant even set the weather or the time. Its there any possiblity to activate that ?

Thanks

Share this post


Link to post
Share on other sites
Dorph;2232007']The mission parameters have to be set within the mission before start.

I am using the Tophe's tool to host the Dynamic Zombie Sandbox Mod 1.25 (Craig's mod) but as you can see inside the game server' date=' the Edit button at the Parameters doesnt exists. Thats what I am talking about...

18787475.th.png

23172915.th.png

Share this post


Link to post
Share on other sites

Hi is there a tool i can connect to TA2DST that allow me to send messages as an admin outside of the game Warnings etc

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×