Jump to content
killswitch

CBA: Community Base Addons for A2, OA and CO

Recommended Posts

Refer to the readme accompanied with each release to know which cba folders you need for which game editions.

Sickboy,

can you confirm that the start parameters I posted above are correct (in regards to CBA and ACE) if I launch Combine ops from steam (click play on ARMA 2: OA and choose combined ops from the dialog).

because as BlackendZ posted the install instructions for ACE and CBA differ in regards to combined ops:

from the ace wiki:

CBA and ACE are always Required

CBA_OA is only required for Operation Arrowhead Standalone users. Combined Ops users should NOT use it.

from the cba installation on dev-heaven:

If you have the "merged" ArmA II: Combined Operations (ArmA II+Arrowhead expansion), use the @CBA, @CBA_A2 and @CBA_OA mod folders.

from my understanding the steam combined ops release is the "merged" version

Share this post


Link to post
Share on other sites

This is how my start parameters looks like when I play Arma2:CO on steam using ACE

-mod=@CBA;@ACE...

Remember to put that in Arma2:OA start parameters and not Arma2.

Share this post


Link to post
Share on other sites

Guys can we stop making this harder than it really is?

Old versions of CBA only require @CBA modfolder to be loaded for CO.

New versions of CBA require @CBA;@CBA_A2;@CBA_OA.

As said, refer to the README included with the release! (That's @CBA\readme.txt)

It doesnt matter what other people or webpages write!

Share this post


Link to post
Share on other sites

Sorry for the wrong answer, I have not updated in a while so thats why it works for me.

Share this post


Link to post
Share on other sites

NP, I get that it is somewhat confusing, not just cause of the change between versions, but also because several sources report differently, which is because there's no official release of the latest version yet.

Hopefully we can release it soon.

In any case, the readme file included with the release should always be used as it belongs to the release.

Share this post


Link to post
Share on other sites

Old versions of CBA only require @CBA modfolder to be loaded for CO.

New versions of CBA require @CBA;@CBA_A2;@CBA_OA.

Thanks for clearing that up!

Share this post


Link to post
Share on other sites
Hi Sickboy, this link for downloading CBA found on devheaven does not work. Dropbox shut it down for causing too much traffic.

http://dl.dropbox.com/u/18252370/CBA/CBA_v1.0.0pre5_binned%2Bsigned.7z

Would it be possible to put the file somewhere else? It does not have to be fast mirror really.

Wanna test the bug with gear menu.

Sure mate, thanks! Ticket updated with latest build (attached) https://dev-heaven.net/issues/30318

Share this post


Link to post
Share on other sites

Hi there!

I'm wondering if it is possible to disable the "You are missing the following mod..." globalChat message? In my case only the server requires CBA, so I would like to turn that off.

Share this post


Link to post
Share on other sites
Hi there!

I'm wondering if it is possible to disable the "You are missing the following mod..." globalChat message? In my case only the server requires CBA, so I would like to turn that off.

On the server you can set this in a server-side-addon or in mission:

CBA_display_ingame_warnings = false;

Btw some features of CBA require it to be running on the client, so I hope the addons do not rely on this functionality ;-)

Share this post


Link to post
Share on other sites

This is exactly what I was looking for! Thanks a lot!

No worries, it's a DayZ only server in this case. CBA is only used for serverSide. I just don't want to confuse all the ArmA newbies with unnecessary warnings. :)

Share this post


Link to post
Share on other sites
This is exactly what I was looking for! Thanks a lot!

No worries, it's a DayZ only server in this case. CBA is only used for serverSide. I just don't want to confuse all the ArmA newbies with unnecessary warnings. :)

DayZ does not use any modifications other than @dayz and @hive. CBA was used on old version with JayArmA2lib, but this has not been used for some time.

  • Like 2

Share this post


Link to post
Share on other sites
On the server you can set this in a server-side-addon or in mission:

CBA_display_ingame_warnings = false;

Just for a quick clarification, I should run that code in a serverside script? In Domi, for example, in i_server? (the init that runs only on the server). Presumably it's a global variable set up by CBA before the mission scripts run?

Share this post


Link to post
Share on other sites

When I start Arma2 it crashes and says "include file x\cba\ui_helper\script_dikCodes.hpp not found". Any idea what's up with that?

Share this post


Link to post
Share on other sites
if i have both arma2 and oa, then i only need @cba, right?
When I start Arma2 it crashes and says "include file x\cba\ui_helper\script_dikCodes.hpp not found". Any idea what's up with that?

Start the game with the appropriate modfolder list, refer to the included readme for details.

Share this post


Link to post
Share on other sites

Ah, I understand now I need to have -mod=@CBA;@CBA_A2;@CBA_OA for my install.Problem is though, that I don't have enough space in the shortcut target line. :confused:

Share this post


Link to post
Share on other sites
Ah, I understand now I need to have -mod=@CBA;@CBA_A2;@CBA_OA for my install.Problem is though, that I don't have enough space in the shortcut target line. :confused:

You can use a batch file instead, or preferably a Launcher.

Also e.g SIX Updater can create shortcuts for you, and it automatically creates batch files when the line is too long.

Share this post


Link to post
Share on other sites

Ok thanks Sickboy. I gotta admit I'm a bit scared of Six Updater lol. :D I'll try it...

Share this post


Link to post
Share on other sites
Ok thanks Sickboy. I gotta admit I'm a bit scared of Six Updater lol. :D I'll try it...
No worries,

hopefully the soon to be introduced Play withSIX will really change that ;-)

Share this post


Link to post
Share on other sites

It's really awesome you keep on working on making it easier to work with Arma2 mods. I have to say Sixupdater is simply too hard for me to use. Play withSix sounds promising. I thought Sixlauncher didn't have enough options. Hopefully Play withSix will have a good balance between features and easy user interface.

Edited by Zorg_DK

Share this post


Link to post
Share on other sites
It's really awesome you keep on working on making it easier to work with Arma2 mods. I have to say Sixupdater is simply too hard for me to use for me. Play withSix sounds promising. I thought Sixlauncher didn't have enough options. Hopefully Play withSix will have a good balance between features and easy user interface.

Thanks, NP :)

Our team is very dedicated and committed to delivering you the best in UI / UserExperience (ease of use), Features and Performance :)

The initial release will replace SIX launcher at first, with already additional features available out of the box, while the more advanced SIX Updater features will follow :)

Stay tuned :)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×